Unpacking .msi Files - Fossology Version 3.8.1

Michael C. Jaeger


please help us a little bit with an example file - an URL to it would be great. I do not have a an *.msi file handy right now and I am not sure if it will be better if you could share the file you re having problems with?

If you feel that is too much of information revealing to the public, you could send the URL to donwload the file(s) in question directly to my e-mail.

Kind regards and if you do not respond earlier, have good start into 2021!

- Michael

On 30. Dec 2020, at 16:36, D Frye <deborah.l.frye@...> wrote:

Everyone was so helpful with the issue of unpacking .deb files in the newer version of Fossology. It looks like there’s also an issue with unpacking .msi files. Has anyone identified a fix for these?

Please let me know.

Thanks – Deb Frye

From: main@... <main@...> On Behalf Of Frye, Deborah L (US)
Sent: Monday, November 9, 2020 9:19 AM
To: main@...
Subject: EXTERNAL: Re: [FOSSology] Unpacking Debian Files - Fossology Version 3.8.1

Thanks for the quick find and fix.

Yes, we did change the base system on which Fossology is running. Our Fossology 3.8.1 instance is deployed to a separate server running Ubuntu 18.04 LTS.

Based on your diagnosis, as a workaround we tried changing /etc/mime.types to point 'deb' files back to the previous MIME type of "application/x-debian-package" but still saw the same behavior. Next we will try a custom compiled version that applies your patch.

Thank you for your prompt response!


From: main@... <main@...> On Behalf Of Gaurav Mishra
Sent: Monday, November 9, 2020 4:24 AM
To: main@...
Subject: EXTERNAL: Re: [FOSSology] Unpacking Debian Files - Fossology Version 3.8.1

Hello Frye,

From what I understood with inconsistency in the unpacking, the deb files were not extracted at all and I tried it on my machine and it didn't work.

It seems like the mimetype of .deb archives was changed (only official document I could find is this https://www.iana.org/assignments/media-types/application/vnd.debian.binary-package).
I have created a PR with the new mimetype which you can find here: https://github.com/fossology/fossology/pull/1831

Also, I was wondering did you changed the base system the fossology is running, as there was no change in the code base related to it?

With best regards,
Gaurav Mishra
From: main@... <main@...> on behalf of D Frye <deborah.l.frye@...>
Sent: 05 November 2020 22:55
To: main@... <main@...>
Subject: [FOSSology] Unpacking Debian Files - Fossology Version 3.8.1

Recently upgraded Fossology to Version 3.8.1. Previous version unpacked and scanned Debian files within FOSS packages; however, seems like new version is not consistently unpacking them. Has anyone else run into this?

Any help would be greatly appreciated.
Deb Frye

Lockheed Martin Corporation
Rotary and Mission Systems (RMS)
Software License Compliance / F-35 3PC Lead
P.O. Box 4840, EP7-C182, MD8
Syracuse, NY 13221-4840
(315) 456-2485